Recent Posts

Hello

After a long search I finally found a proper DL version of this mighty awesome game.
I bought this game on pc back in '99 but unfortunately both discs were lost when moving out. Still bummed out about this.
Now that I'm trying to get it up and running a small problem occurred.
I've mounted disc one and followed setup instructions. At 80% setup asked for disc 2.
After doing this setup reached 100% and did a directx update.
I thought YAAYY IT'S GO TIME but my pc said nonono hombre I won't cooperate.
An error popped on my screen, showing me a "incorrect installation" messsage.
Does anyone know how to fix this please?
Schermopname (92).png

Doing a re-install didn't really help, weird thing about it is that this time I got a different error.
Telling me machines.exe is missing and a problem in machines path.
Installing the machines XP patch and d3drm.dll file didn't fix it.
Due to my basic pc knowledge I ran out of options.
Schermopname (95).png Schermopname (94).png

posted in Downloads read more

Hello,
I was so excited when I found out about this forum and a downloadlink somewhere. Did what had to be done so the game and menus were loading I was like ooh finallyyyyy, until I tried to play it.
I can barely see anything..
I'm using windows 8.1, already tried it with compatibilitymode on windows xp and also on windows 98 mode.
Back in '99 I had the original game on discs and played it on a windows 98 pc.
Somehow, even then, the same visual errors already occured frequently, not always, but more like 6/10 times
Anyone who might know the problem or a solution here?
I reeeaaally want to play this game again

Greetings
Schermopname (32).png

posted in General Discussion read more

@Asdam
I have the same problem. Have you been able to fix it?
I was so excited when the game and menus were loading, until I tried to play it
windows 8.1 with compatibilitymode on windows xp and also tried it on windows 98 mode.
Back in '99 i had the original game on discs and played it on a windows 98 pc.
Somehow, even then, the same visual errors occured frequently, not always, but more like 6/10 times
Anyone who might know a solution here?

Schermopname (32).png

posted in Machines read more